
<!doctype html>
<!--[if lt IE 7]><html class="no-js ie ie6 lt-ie9 lt-ie8 lt-ie7" lang="en-US"> <![endif]-->
<!--[if IE 7]><html class="no-js ie ie7 lt-ie9 lt-ie8" lang="en-US"> <![endif]-->
<!--[if IE 8]><html class="no-js ie ie8 lt-ie9" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--><html class="no-js" lang="en-US"> <!--<![endif]-->
<head>
    <meta charset="UTF-8" />
        <title>
                            The Convenient Truth of Rotisserie Chicken | TASTE
                    </title>
    <meta name="description" content="An online magazine for today&#039;s home cook, reporting from the front lines of dinner.">
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge"><script type="text/javascript">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</script>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <!-- pinterest verification -->
    <meta name="p:domain_verify" content="10fcb36f043bc390844ae1dfbe5ee230"/>
    <!-- end pinterest verification -->
    <link rel="pingback" href="https://www.tastecooking.com/xmlrpc.php" />

    <!-- favicon -->
    <link rel="apple-touch-icon" sizes="57x57" href="/wp-content/themes/taste2/static/img/favicons/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="/wp-content/themes/taste2/static/img/favicons/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="/wp-content/themes/taste2/static/img/favicons/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="/wp-content/themes/taste2/static/img/faviconsapple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="/wp-content/themes/taste2/static/img/favicons/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="/wp-content/themes/taste2/static/img/favicons/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="/wp-content/themes/taste2/static/img/favicons/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="/wp-content/themes/taste2/static/img/favicons/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="/wp-content/themes/taste2/static/img/favicons/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192"  href="/wp-content/themes/taste2/static/img/favicons/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="/wp-content/themes/taste2/static/img/favicons/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="/wp-content/themes/taste2/static/img/favicons/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="/wp-content/themes/taste2/static/img/favicons/favicon-16x16.png">
<link rel="shortcut icon" href="/wp-content/themes/taste2/static/img/favicons/favicon.ico" type="image/x-icon" />
<link rel="manifest" href="/wp-content/themes/taste2/static/img/favicons/manifest.json">
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="/wp-content/themes/taste2/static/img/favicons/ms-icon-144x144.png">
<meta name="theme-color" content="#ffffff">

    <!-- load PRH newsletter widget -->
    <script type="text/javascript">
        !function(e,t,a){window.PRHWidgets={},window.PRHWidgets.ready=function(d){var n,o=e.getElementsByTagName(t)[0],c=!1;e.getElementById(a)||(n=e.createElement(t),n.id=a,n.async=!0,n.src=e.location.protocol+"//widgets.penguinrandomhouse.com/Include/JS/V2.0/ScriptPackage.ashx?widgetid=19",n.onreadystatechange=n.onload=function(){n.readyState&&"complete"!==n.readyState&&"loaded"!==n.readyState||c||(c=!0,PRHWidgets.$&&PRHWidgets.$(document).ready(d))},o.parentNode.insertBefore(n,o))}}(document,"script","prh-jssdk");
    </script>

    <!-- Pinterest -->
    <meta name="p:domain_verify" content="b9b5556de5883f3fe30cbca41544265c"/>
    <!-- End Pinterest -->

    <!-- Keywee -->
    <script>
    (function(w,d) {
        w.kwa || (w.kwa = function() {
            (w.kwa.q = w.kwa.q || []).push(arguments);
        });
        se = d.createElement('script'),
        fs = d.scripts[0];
        se.src = '//cdn.keywee.co/dist/analytics.min.js';
        fs.parentNode.insertBefore(se,fs)
    }(window, document));
    </script>

    <script>
    kwa('initialize',259);
    </script>
    <!-- End Keywee -->

    
	<!-- This site is optimized with the Yoast SEO plugin v14.8.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="description" content="A look at America’s favorite illogically cheap, ecologically dubious roasted chicken." />
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.tastecooking.com/the-convenient-truth-of-rotisserie-chicken/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="The Convenient Truth of Rotisserie Chicken" />
	<meta property="og:description" content="A look at America’s favorite illogically cheap, ecologically dubious roasted chicken." />
	<meta property="og:url" content="https://www.tastecooking.com/the-convenient-truth-of-rotisserie-chicken/" />
	<meta property="og:site_name" content="TASTE" />
	<meta property="article:published_time" content="2020-08-18T08:00:24+00:00" />
	<meta property="article:modified_time" content="2020-08-18T15:48:05+00:00" />
	<meta property="og:image" content="https://www.tastecooking.com/wp-content/uploads/2020/08/Social-Rotisserie-Chicken.jpg" />
	<meta property="og:image:width" content="1200" />
	<meta property="og:image:height" content="628" />
	<meta name="twitter:card" content="summary_large_image" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.tastecooking.com/#website","url":"https://www.tastecooking.com/","name":"TASTE","description":"An online magazine for today&#039;s home cook, reporting from the front lines of dinner.","potentialAction":[{"@type":"SearchAction","target":"https://www.tastecooking.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.tastecooking.com/the-convenient-truth-of-rotisserie-chicken/#primaryimage","inLanguage":"en-US","url":"https://www.tastecooking.com/wp-content/uploads/2020/08/Article-Rotisserie-Chicken.gif","width":1200,"height":675,"caption":"Rotisserie Chicken"},{"@type":"WebPage","@id":"https://www.tastecooking.com/the-convenient-truth-of-rotisserie-chicken/#webpage","url":"https://www.tastecooking.com/the-convenient-truth-of-rotisserie-chicken/","name":"The Convenient Truth of Rotisserie Chicken","isPartOf":{"@id":"https://www.tastecooking.com/#website"},"primaryImageOfPage":{"@id":"https://www.tastecooking.com/the-convenient-truth-of-rotisserie-chicken/#primaryimage"},"datePublished":"2020-08-18T08:00:24+00:00","dateModified":"2020-08-18T15:48:05+00:00","author":{"@id":"https://www.tastecooking.com/#/schema/person/3fe4048617d338e2fa4785689ae05401"},"description":"A look at America\u2019s favorite illogically cheap, ecologically dubious roasted chicken.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.tastecooking.com/the-convenient-truth-of-rotisserie-chicken/"]}]},{"@type":"Person","@id":"https://www.tastecooking.com/#/schema/person/3fe4048617d338e2fa4785689ae05401","name":"Cathy Erway","image":{"@type":"ImageObject","@id":"https://www.tastecooking.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/98abbb147877e9105d5c4533b258c2b5?s=96&d=mm&r=g","caption":"Cathy Erway"},"description":"Cathy Erway is the author of the cookbook The Food of Taiwan and the memoir The Art of Eating In. She hosts the podcasts Self Evident, exploring Asian American stories, and Eat Your Words on Heritage Radio Network, and blogs at Not Eating Out in New York."}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.tastecooking.com' />
<link rel='dns-prefetch' href='//a.omappapi.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="TASTE &raquo; The Convenient Truth of Rotisserie Chicken Comments Feed" href="https://www.tastecooking.com/the-convenient-truth-of-rotisserie-chicken/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.tastecooking.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.tastecooking.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://www.tastecooking.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='tb_stylesheet-css'  href='https://www.tastecooking.com/wp-content/themes/taste2/static/build/css/screen.css?ver=2.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='crown-tracking-styles-css'  href='https://www.tastecooking.com/wp-content/plugins/mit-tracking/assets/css/crown-tracking.css?ver=5.5' type='text/css' media='all' />
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/www.tastecooking.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":115299,"token":"b5d4fd4981","lang":0,"debug":0}
</script>
<script type='text/javascript' src='https://www.tastecooking.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.2.3' id='wpp-js-js'></script>
<script type='text/javascript' src='https://www.tastecooking.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-js'></script>
<script type='text/javascript' src='https://www.tastecooking.com/wp-content/themes/taste2/static/build/lib/modernizr/modernizr.js?ver=5.5' id='modern-js'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.tastecooking.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.tastecooking.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5" />
<link rel='shortlink' href='https://www.tastecooking.com/?p=115299' />
<link rel="alternate" type="application/json+oembed" href="https://www.tastecooking.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.tastecooking.com%2Fthe-convenient-truth-of-rotisserie-chicken%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.tastecooking.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.tastecooking.com%2Fthe-convenient-truth-of-rotisserie-chicken%2F&#038;format=xml" />
    <script type="text/javascript">
   	var utag_data = {}
   	</script>
   	<!-- Loading script asynchronously -->
   	<script type="text/javascript">
   	    (function(a,b,c,d){
   	    a='//tags.tiqcdn.com/utag/random/rh-crown/prod/utag.js';
   	    b=document;c='script';d=b.createElement(c);d.src=a;d.type='text/java'+c;d.async=true;
   	    a=b.getElementsByTagName(c)[0];a.parentNode.insertBefore(d,a);
   	    })();
   	</script>
                  <script>
                    if ( typeof ga === 'undefined' ) {
                        (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
                        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
                        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
                        })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

                        ga( 'create','UA-75428710-9', 'auto' );                        ga('send', 'pageview');
                    }
                </script>

            
      </head>

  <body class="post-template-default single single-post postid-115299 single-format-standard" data-template="base.twig">

    <div class="mobile-menu">
  <input class="checkbox-toggle" type="checkbox" />
  <div class="hamburger">
    <div></div>
  </div>

  <div class="mobile-menu__logo">
    <a href="https://www.tastecooking.com"> <svg width="140" height="43" viewBox="0 0 140 43" fill="none" xmlns="http://www.w3.org/2000/svg">
<path d="M17.0912 42.4512H8.88497V7.52832H0V0.494385H25.9762V7.52832H17.0912V42.4512Z" fill="black"/>
<path d="M38.684 42.4504H30.4778V11.4764C30.4778 8.02115 31.6193 5.2446 33.9022 3.14676C36.1851 1.04892 39.1345 0 42.7563 0C46.4584 0 49.42 1.03658 51.6413 3.11591C53.8625 5.19524 54.9732 7.97796 54.9732 11.4764V42.4504H46.7669V34.1208H38.684V42.4504ZM38.684 12.2168V27.0868H46.7669V12.2168C46.7669 10.6928 46.409 9.47113 45.6871 8.54561C44.9652 7.6201 43.9903 7.15734 42.7563 7.15734C41.4791 7.15734 40.4857 7.60776 39.7638 8.51476C39.0419 9.42177 38.684 10.6558 38.684 12.2168Z" fill="black"/>
<path d="M84.7774 31.4676C84.7774 34.8427 83.6051 37.5945 81.2604 39.7356C78.9158 41.8766 75.9109 42.944 72.2521 42.944C68.6734 42.944 65.7549 41.9075 63.4905 39.8281C61.2261 37.7488 60.0969 34.9846 60.0969 31.5293V29.1847H67.7479V31.2208C67.7479 32.5782 68.1674 33.6889 69.0127 34.5527C69.858 35.4165 70.9563 35.8484 72.3138 35.8484C73.5478 35.8484 74.5535 35.4658 75.3371 34.7069C76.1207 33.948 76.5094 32.9299 76.5094 31.6527C76.5094 30.7889 76.2626 30.0176 75.769 29.3389C75.2754 28.6602 74.3067 27.7655 72.8691 26.6549L67.0075 22.2741C64.6196 20.5033 62.892 18.7448 61.8246 16.9987C60.7571 15.2525 60.2203 13.346 60.2203 11.2913C60.2203 8.00264 61.3803 5.29396 63.7064 3.17761C66.0264 1.06126 68.9572 0 72.4989 0C76.0343 0 78.8973 1.04892 81.0753 3.14676C83.2534 5.2446 84.3455 8.06435 84.3455 11.5998V13.636H76.6945V11.7849C76.6945 10.3843 76.3058 9.26752 75.5222 8.42221C74.7386 7.57691 73.7144 7.15734 72.4372 7.15734C71.2031 7.15734 70.2283 7.50904 69.5064 8.20626C68.7845 8.90348 68.4266 9.829 68.4266 10.9828C68.4266 11.7664 68.6734 12.5377 69.167 13.2966C69.6606 14.0555 70.4195 14.8268 71.4499 15.6104L78.2371 20.855C80.5817 22.706 82.26 24.4522 83.2657 26.0996C84.2714 27.747 84.7774 29.5364 84.7774 31.4676Z" fill="black"/>
<path d="M104.211 42.4512H96.0049V7.52832H87.1199V0.494385H113.096V7.52832H104.211V42.4512Z" fill="black"/>
<path d="M140 42.4512H118.219V0.494385H140V7.52832H126.425V17.7707H139.753V24.8047H126.425V35.4173H140V42.4512Z" fill="black"/>
</svg>
 </a>
  </div>

  <div class="nav-search-button">
    <div class="nav-search-svg ga-search-button"><svg width="19px" height="19px" viewBox="0 0 19 19" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
    <g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <path d="M5.50619839,11.616766 C4.56198538,10.3979239 4,8.86806528 4,7.20694795 C4,3.22666051 7.22666051,0 11.206948,0 C15.1872354,0 18.4138959,3.22666051 18.4138959,7.20694795 C18.4138959,11.1872354 15.1872354,14.4138959 11.206948,14.4138959 C9.60074404,14.4138959 8.11726395,13.8884527 6.91902093,13.0000796 C6.88751372,13.0436324 6.85208138,13.0853262 6.81271478,13.1246928 L1.71079688,18.2266107 C1.31841004,18.6189975 0.686457829,18.6232301 0.293210874,18.2299831 C-0.0973134179,17.8394588 -0.0992840225,17.2082645 0.296583322,16.8123971 L5.39850122,11.7104792 C5.43268729,11.6762932 5.46869177,11.6450534 5.50619839,11.616766 Z M11.206948,12.4138959 C14.0826659,12.4138959 16.4138959,10.0826659 16.4138959,7.20694795 C16.4138959,4.33123001 14.0826659,2 11.206948,2 C8.33123001,2 6,4.33123001 6,7.20694795 C6,10.0826659 8.33123001,12.4138959 11.206948,12.4138959 Z" fill="#000000"></path>
    </g>
</svg>
</div>
  </div>

  <div class="menu-items">
    <div>

      <div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-111199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-111199"><a href="/features/">Features</a>
<ul class="sub-menu">
	<li id="menu-item-111226" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111226"><a href="https://www.tastecooking.com/category/cooking/">Cooking</a></li>
	<li id="menu-item-111227" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111227"><a href="https://www.tastecooking.com/category/culture/">Culture</a></li>
</ul>
</li>
<li id="menu-item-111202" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-111202"><a href="https://www.tastecooking.com/category/columns/">Columns</a>
<ul class="sub-menu">
	<li id="menu-item-112395" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112395"><a href="https://www.tastecooking.com/category/columns/100-questions-for-my-friend-the-chef/">100 Questions for My Friend the Chef</a></li>
	<li id="menu-item-111293" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111293"><a href="https://www.tastecooking.com/category/columns/a-kitchen-in-new-orleans/">A Kitchen In New Orleans</a></li>
	<li id="menu-item-111294" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111294"><a href="https://www.tastecooking.com/category/columns/americas-best-worst-cook/">America’s Best Worst Cook</a></li>
	<li id="menu-item-113221" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-113221"><a href="https://www.tastecooking.com/category/columns/know-your-chicken/">Know Your Chicken</a></li>
	<li id="menu-item-111316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111316"><a href="https://www.tastecooking.com/category/columns/lets-talk-about-american-food/">Let’s Talk About American Food</a></li>
	<li id="menu-item-111317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111317"><a href="https://www.tastecooking.com/category/columns/the-countrys-best-yogurt-column/">The Country’s Best Yogurt Column</a></li>
</ul>
</li>
<li id="menu-item-111203" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-111203"><a href="https://www.tastecooking.com/category/issues/">Issues</a>
<ul class="sub-menu">
	<li id="menu-item-111311" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111311"><a href="/collections/the-coffee-issue/">The Coffee Issue</a></li>
	<li id="menu-item-111312" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111312"><a href="/collections/the-90s-issue/">The 90s Issue</a></li>
	<li id="menu-item-111313" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111313"><a href="/collections/the-emilia-romagna-issue/">The Emilia-Romagna Issue</a></li>
	<li id="menu-item-111314" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111314"><a href="/collections/the-can-issue/">The Can Issue</a></li>
	<li id="menu-item-111315" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111315"><a href="/collections/israel-issue/">The Israel Issue</a></li>
	<li id="menu-item-113482" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113482"><a href="/collections/the-pepper-issue/">The Pepper Issue</a></li>
</ul>
</li>
<li id="menu-item-111204" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111204"><a href="/recipes/">Recipes</a></li>
</ul></div>

        <ul class="menu">
          <li class="menu-item">
            <a href="/newsletter">Subscribe</a>
          </li>
          <li class="menu-item">
            <a href="/about_us">About</a>
          </li>
        </ul>

    </div>
  </div>

  <!--<div class="menu-items">
    <div>
      <ul>
        <li><a href="/features" class="ga-topnav-features">Features</a></li>
        <li><a href="/recipes" class="ga-topnav-recipes">Recipes</a></li>
        <li><a href="/newsletter" class="ga-topnav-subscribe">Subscribe</a></li>
        <li><a href="/about_us" class="ga-topnav-about">About</a></li>
      </ul>
      <a href="https://www.tastecooking.com"><img src="/wp-content/themes/taste2/static/img/taste-icon.svg" alt="Taste Icon" /></a>
    </div>
  </div>-->
</div>

          <header id="header">
          <div class="search-pulldown">

  <div class="search-form-container">
    <form method="get" class="search-form" action="https://www.tastecooking.com/wp-admin/admin-post.php">
        <input type="hidden" name="action" value="search_form"/>
        <input name="q" class="search-form-input" id="search-form-input" type="search" placeholder="What are you looking for?" onfocus="if (this.placeholder == 'What are you looking for?') {this.placeholder = '';}" onblur="if (this.placeholder == '') {this.placeholder = 'What are you looking for?';}" />

        <label class="search-form-label">
          <input type="submit"/>
          <svg width="30px" height="24px" viewBox="0 0 30 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
    <g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <path d="M25.1066017,14 L1.50826408,14 C0.675272828,14 0,13.3342028 0,12.5 C0,11.6715729 0.66865487,11 1.50826408,11 L24.8786797,11 L17.3596604,3.48098073 C16.7705011,2.89182149 16.763683,1.94342382 17.3535534,1.35355339 C17.9393398,0.767766953 18.8854438,0.764123424 19.4809807,1.35966038 L29.3682617,11.2469413 C29.401523,11.2802026 29.4329282,11.3146089 29.4624748,11.350031 C29.7911519,11.6242356 30,12.0360756 30,12.5 C30,12.8022183 29.9110113,13.0835615 29.7571978,13.3190394 C29.6891042,13.5611431 29.5592958,13.7899466 29.3682617,13.9809807 L19.4809807,23.8682617 C18.8854438,24.4637986 17.9393398,24.4601551 17.3535534,23.8743687 C16.763683,23.2844982 16.7705011,22.3361006 17.3596604,21.7469413 L25.1066017,14 Z" fill="#F8F5E3"></path>
    </g>
</svg>
        </label>
    </form>
  </div>

  <div class="search-close">
    <div class="search-close-x"></div>
  </div>

</div>

          <div class="navigation-bar navigation-bar--white">
  <div class="navigation-bar__container">

    <a href="https://www.tastecooking.com" class="navigation-bar__brand"> <svg width="140" height="43" viewBox="0 0 140 43" fill="none" xmlns="http://www.w3.org/2000/svg">
<path d="M17.0912 42.4512H8.88497V7.52832H0V0.494385H25.9762V7.52832H17.0912V42.4512Z" fill="black"/>
<path d="M38.684 42.4504H30.4778V11.4764C30.4778 8.02115 31.6193 5.2446 33.9022 3.14676C36.1851 1.04892 39.1345 0 42.7563 0C46.4584 0 49.42 1.03658 51.6413 3.11591C53.8625 5.19524 54.9732 7.97796 54.9732 11.4764V42.4504H46.7669V34.1208H38.684V42.4504ZM38.684 12.2168V27.0868H46.7669V12.2168C46.7669 10.6928 46.409 9.47113 45.6871 8.54561C44.9652 7.6201 43.9903 7.15734 42.7563 7.15734C41.4791 7.15734 40.4857 7.60776 39.7638 8.51476C39.0419 9.42177 38.684 10.6558 38.684 12.2168Z" fill="black"/>
<path d="M84.7774 31.4676C84.7774 34.8427 83.6051 37.5945 81.2604 39.7356C78.9158 41.8766 75.9109 42.944 72.2521 42.944C68.6734 42.944 65.7549 41.9075 63.4905 39.8281C61.2261 37.7488 60.0969 34.9846 60.0969 31.5293V29.1847H67.7479V31.2208C67.7479 32.5782 68.1674 33.6889 69.0127 34.5527C69.858 35.4165 70.9563 35.8484 72.3138 35.8484C73.5478 35.8484 74.5535 35.4658 75.3371 34.7069C76.1207 33.948 76.5094 32.9299 76.5094 31.6527C76.5094 30.7889 76.2626 30.0176 75.769 29.3389C75.2754 28.6602 74.3067 27.7655 72.8691 26.6549L67.0075 22.2741C64.6196 20.5033 62.892 18.7448 61.8246 16.9987C60.7571 15.2525 60.2203 13.346 60.2203 11.2913C60.2203 8.00264 61.3803 5.29396 63.7064 3.17761C66.0264 1.06126 68.9572 0 72.4989 0C76.0343 0 78.8973 1.04892 81.0753 3.14676C83.2534 5.2446 84.3455 8.06435 84.3455 11.5998V13.636H76.6945V11.7849C76.6945 10.3843 76.3058 9.26752 75.5222 8.42221C74.7386 7.57691 73.7144 7.15734 72.4372 7.15734C71.2031 7.15734 70.2283 7.50904 69.5064 8.20626C68.7845 8.90348 68.4266 9.829 68.4266 10.9828C68.4266 11.7664 68.6734 12.5377 69.167 13.2966C69.6606 14.0555 70.4195 14.8268 71.4499 15.6104L78.2371 20.855C80.5817 22.706 82.26 24.4522 83.2657 26.0996C84.2714 27.747 84.7774 29.5364 84.7774 31.4676Z" fill="black"/>
<path d="M104.211 42.4512H96.0049V7.52832H87.1199V0.494385H113.096V7.52832H104.211V42.4512Z" fill="black"/>
<path d="M140 42.4512H118.219V0.494385H140V7.52832H126.425V17.7707H139.753V24.8047H126.425V35.4173H140V42.4512Z" fill="black"/>
</svg>
 </a>

    <div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-111199" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-111199"><a href="/features/">Features</a>
<ul class="sub-menu">
	<li id="menu-item-111226" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111226"><a href="https://www.tastecooking.com/category/cooking/">Cooking</a></li>
	<li id="menu-item-111227" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111227"><a href="https://www.tastecooking.com/category/culture/">Culture</a></li>
</ul>
</li>
<li id="menu-item-111202" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-111202"><a href="https://www.tastecooking.com/category/columns/">Columns</a>
<ul class="sub-menu">
	<li id="menu-item-112395" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112395"><a href="https://www.tastecooking.com/category/columns/100-questions-for-my-friend-the-chef/">100 Questions for My Friend the Chef</a></li>
	<li id="menu-item-111293" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111293"><a href="https://www.tastecooking.com/category/columns/a-kitchen-in-new-orleans/">A Kitchen In New Orleans</a></li>
	<li id="menu-item-111294" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111294"><a href="https://www.tastecooking.com/category/columns/americas-best-worst-cook/">America’s Best Worst Cook</a></li>
	<li id="menu-item-113221" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-113221"><a href="https://www.tastecooking.com/category/columns/know-your-chicken/">Know Your Chicken</a></li>
	<li id="menu-item-111316" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111316"><a href="https://www.tastecooking.com/category/columns/lets-talk-about-american-food/">Let’s Talk About American Food</a></li>
	<li id="menu-item-111317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111317"><a href="https://www.tastecooking.com/category/columns/the-countrys-best-yogurt-column/">The Country’s Best Yogurt Column</a></li>
</ul>
</li>
<li id="menu-item-111203" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-111203"><a href="https://www.tastecooking.com/category/issues/">Issues</a>
<ul class="sub-menu">
	<li id="menu-item-111311" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111311"><a href="/collections/the-coffee-issue/">The Coffee Issue</a></li>
	<li id="menu-item-111312" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111312"><a href="/collections/the-90s-issue/">The 90s Issue</a></li>
	<li id="menu-item-111313" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111313"><a href="/collections/the-emilia-romagna-issue/">The Emilia-Romagna Issue</a></li>
	<li id="menu-item-111314" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111314"><a href="/collections/the-can-issue/">The Can Issue</a></li>
	<li id="menu-item-111315" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111315"><a href="/collections/israel-issue/">The Israel Issue</a></li>
	<li id="menu-item-113482" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-113482"><a href="/collections/the-pepper-issue/">The Pepper Issue</a></li>
</ul>
</li>
<li id="menu-item-111204" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-111204"><a href="/recipes/">Recipes</a></li>
</ul></div>

    <div class="nav-static">
      <div class="menu">
        <div class="menu-item">
          <a href="/newsletter">Subscribe</a>
        </div>
        <div class="menu-item">
          <a href="/about_us">About</a>
        </div>
      </div>
    </div>

    <div class="nav-search-button">
      <div class="nav-search-svg ga-search-button"><svg width="19px" height="19px" viewBox="0 0 19 19" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
    <g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <path d="M5.50619839,11.616766 C4.56198538,10.3979239 4,8.86806528 4,7.20694795 C4,3.22666051 7.22666051,0 11.206948,0 C15.1872354,0 18.4138959,3.22666051 18.4138959,7.20694795 C18.4138959,11.1872354 15.1872354,14.4138959 11.206948,14.4138959 C9.60074404,14.4138959 8.11726395,13.8884527 6.91902093,13.0000796 C6.88751372,13.0436324 6.85208138,13.0853262 6.81271478,13.1246928 L1.71079688,18.2266107 C1.31841004,18.6189975 0.686457829,18.6232301 0.293210874,18.2299831 C-0.0973134179,17.8394588 -0.0992840225,17.2082645 0.296583322,16.8123971 L5.39850122,11.7104792 C5.43268729,11.6762932 5.46869177,11.6450534 5.50619839,11.616766 Z M11.206948,12.4138959 C14.0826659,12.4138959 16.4138959,10.0826659 16.4138959,7.20694795 C16.4138959,4.33123001 14.0826659,2 11.206948,2 C8.33123001,2 6,4.33123001 6,7.20694795 C6,10.0826659 8.33123001,12.4138959 11.206948,12.4138959 Z" fill="#000000"></path>
    </g>
</svg>
</div>
    </div>

  </div>
</div>

      </header>
    
    <section id="content" role="main" class="main-content">

      <div id="pjax-container">
          <div class="wrapper ">
            
  <section class="newsletter-ad">

  <div class="newsletter-ad-left">
    <div class="newsletter-ad-text">Sign up for our newsletter</div>
  </div>
      &nbsp;&nbsp;
  
  <div class="newsletter-ad-right">
    <div class="newsletter-ad-text">Get a free recipe</div>
    <a href="https://www.tastecooking.com/newsletter/" class="button button--light--outline--small">Subscribe</a>
  </div>

</section>

  
	<div class="content-wrapper">
		<article class="post-type-post" id="post-115299">
			<section class="article-content">

                  <section class="article-header--inline-image article-header--inline-image--wide">

  <div class="article-header-text">
        <div class="article-header-subheader">
      <div class="article-header-date">
                  August 18, 2020
              </div>
    </div>
        <div class="article-header-title">The Convenient Truth of Rotisserie Chicken</div>
    <div class="article-header-byline">
      <span class="article-header-author">By: <a href="https://www.tastecooking.com/author/cerway">Cathy Erway</a></span>            <span class="article-header-attribution">Animation: <a href="https://elianarodgers.com/" target="_blank">Eliana Rodgers</a></span>
                </div>
    <div class="share-button">
      <div class="share-links">
      <div class="share-link-icon share-link-icon--facebook ga-share-facebook">
      <a href="https://www.facebook.com/sharer/sharer.php?u=https://www.tastecooking.com/the-convenient-truth-of-rotisserie-chicken/" target="_blank" class="facebook"> <svg width="12px" height="23px" viewBox="0 0 12 25" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
    <g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <path d="M7.97967893,25 L2.65880919,25 L2.65880919,12.4984221 L0,12.4984221 L0,8.19079778 L2.65880919,8.19079778 L2.65880919,5.60464529 C2.65880919,2.09069679 4.15931721,0 8.42511685,0 L11.9756147,0 L11.9756147,4.30920222 L9.75655355,4.30920222 C8.09591546,4.30920222 7.98618167,4.91116511 7.98618167,6.03461878 L7.97886608,8.19079778 L12,8.19079778 L11.529364,12.4984221 L7.97886608,12.4984221 L7.97886608,25 L7.97967893,25 Z" id="facebook" fill="#000000"></path>
    </g>
</svg>
 </a>
    </div>
    <div class="share-link-icon share-link-icon--twitter ga-share-twitter">
      <a href="https://twitter.com/home?status=https://www.tastecooking.com/the-convenient-truth-of-rotisserie-chicken/" target="_blank" class="twitter"> <svg width="26px" height="23px" viewBox="0 0 27 23" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
    <g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <path d="M23.1891933,3.63621262 C24.3031385,2.91860465 25.1578833,1.7807309 25.559027,0.425249169 C24.5160533,1.09136213 23.3635365,1.5730897 22.1338767,1.83388704 C21.1526174,0.704318937 19.7501572,0 18.1980396,0 C15.2203188,0 12.807285,2.59966777 12.807285,5.80564784 C12.807285,6.26079734 12.8520279,6.70431894 12.9445996,7.12790698 C8.46413269,6.88538206 4.49126691,4.57641196 1.82983255,1.06146179 C1.36543154,1.92192691 1.10005953,2.91860465 1.10005953,3.98172757 C1.10005953,5.99501661 2.05200446,7.77242525 3.49920761,8.81561462 C2.61514854,8.78571429 1.78354673,8.52159468 1.05531658,8.089701 L1.05531658,8.16112957 C1.05531658,10.9750831 2.91292062,13.3222591 5.38304027,13.8538206 C4.92943929,13.9900332 4.45423825,14.0581395 3.9605229,14.0581395 C3.61337928,14.0581395 3.27394997,14.0232558 2.94686355,13.9551495 C3.63189361,16.2607973 5.62372651,17.9418605 7.98430307,17.986711 C6.13749906,19.5448505 3.81240829,20.4717608 1.28674565,20.4717608 C0.851658994,20.4717608 0.421200916,20.4468439 0,20.3920266 C2.38680519,22.038206 5.22103992,23 8.26664654,23 C18.1872395,23 23.6088513,14.1528239 23.6088513,6.48006645 C23.6088513,6.22757475 23.6057656,5.97674419 23.5949656,5.72923588 C24.6487393,4.910299 25.5651984,3.88704319 26.2857143,2.72259136 C25.3183408,3.18438538 24.2784528,3.49667774 23.1891933,3.63621262 Z" fill="#000000"></path>
    </g>
</svg>
 </a>
    </div>
  
    <div class="share-link-icon share-link-icon--pinterest ga-share-pinterest">
    <a href="https://pinterest.com/pin/create/button/?url=https://www.tastecooking.com/the-convenient-truth-of-rotisserie-chicken/&media=https://www.tastecooking.com/wp-content/uploads/2020/08/Article-Rotisserie-Chicken.gif&description=The Convenient Truth of Rotisserie Chicken" class="pinterest" target="_blank"> <svg width="24px" height="24px" viewBox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
    <g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <path d="M7.627,23.174 C7.522,22.225 7.427,20.769 7.669,19.733 C7.887,18.796 9.076,13.768 9.076,13.768 C9.076,13.768 8.717,13.049 8.717,11.986 C8.717,10.318 9.684,9.072 10.888,9.072 C11.911,9.072 12.406,9.841 12.406,10.762 C12.406,11.791 11.751,13.33 11.412,14.757 C11.129,15.951 12.011,16.926 13.189,16.926 C15.322,16.926 16.961,14.677 16.961,11.431 C16.961,8.558 14.897,6.549 11.949,6.549 C8.535,6.549 6.531,9.11 6.531,11.756 C6.531,12.787 6.928,13.894 7.424,14.494 C7.522,14.613 7.536,14.718 7.507,14.839 L7.174,16.199 C7.121,16.419 7,16.466 6.772,16.36 C5.273,15.662 4.336,13.471 4.336,11.711 C4.336,7.926 7.086,4.449 12.265,4.449 C16.428,4.449 19.663,7.416 19.663,11.38 C19.663,15.516 17.056,18.844 13.436,18.844 C12.22,18.844 11.077,18.213 10.686,17.466 L9.938,20.319 C9.667,21.362 8.936,22.669 8.446,23.465 C9.57,23.812 10.763,24 12,24 C18.627,24 24,18.627 24,12 C24,5.372 18.627,0 12,0 C5.373,-3.55271368e-15 0,5.372 0,12 C0,17.084 3.163,21.426 7.627,23.174 Z" fill="#000000"></path>
    </g>
</svg>
 </a>
  </div>
  
      <div class="share-link-icon share-link-icon--email ga-share-email">
      <a href="mailto:?&body=https://www.tastecooking.com/the-convenient-truth-of-rotisserie-chicken/" class="email"> <svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M12 12.713l-11.985-9.713h23.97l-11.985 9.713zm0 2.574l-12-9.725v15.438h24v-15.438l-12 9.725z"></path></svg>
 </a>
    </div>
  </div>
    </div>
      </div>

    <img src="https://www.tastecooking.com/wp-content/uploads/2020/08/Article-Rotisserie-Chicken.gif" alt="Article-Rotisserie-Chicken">
  
</section>
        
        <div class="article-body">
            
            
          <h1><strong>A look at America’s favorite illogically cheap, ecologically dubious roasted chicken.</strong></h1>
<p>Emma Feigenbaum remembers when she first dropped a rotisserie chicken into her basket in the supermarket. She was about twelve, on vacation with her family on Long Island. At home, she enjoyed home-cooked meals almost every night, and prepared foods were not something that her family typically bought. Then she turned a corner and arrived at the warm, glowing display of rust-colored birds.</p>
<p>“It was revelatory,” Feigenbaum recalls. “I remember thinking to myself, <em>It’s a whole roast chicken, I don’t have to roast a chicken</em>.”</p>
<p>Her practical purchase was further justified upon a taste test; Feigenbaum was blown away by its flavor, the sticky skin and crispy wing tips. Even if the breast meat was a little dry (it’s always a little dry), nowadays she finds the slightly chewy breast meat of a supermarket rotisserie chicken appealingly nostalgic. Since then, rotisserie chicken has stuck around as occasional stand-in for home-cooked dinners, and it’s had an immense presence in her work—Feigenbaum is a <a href="https://emmafeigenbaum.com/" target="_blank" rel="noopener noreferrer">food stylist and chef</a>, and she has previously served as a food editor for <em>Martha Stewart Living</em>. She says that when styling any recipe that involves shredded chicken meat, it’s a no-brainer. “It looks the same as if I’m spending $16 for a Bell &amp; Evans [raw chicken],” she says. “It’s not a better or worse product than what you roast at home, just a more convenient one.”</p>
<p>Roasting a whole chicken at home is a rite of passage for nearly everybody who has turned on an oven, and for avid home cooks, perfecting one can border on a spiritual quest. There are numerous gurus of the craft, as well as buzzworthy home hacks, from spatchcocking to brining to using <a href="https://www.newyorker.com/culture/annals-of-gastronomy/yes-i-use-a-hair-dryer-to-make-roast-chicken" target="_blank" rel="noopener noreferrer">a hair dryer</a> to ensure a crisp skin and juicy meat. Roasted chicken is the entrée that many food critics regard as a “<a href="https://www.bonappetit.com/restaurants-travel/article/when-do-you-order-the-chicken" target="_blank" rel="noopener noreferrer">litmus test</a>” for a restaurant’s worth—and it is essentially beloved all around the globe. Yet going out of one’s way to roast a chicken at home seems futile when there is a hot, glistening, extremely delicious roasted bird a few aisles away, priced as low as a bag of chips. And an entire generation has been raised with them around.</p>
<p>In the United States, rotisserie chickens are available for an ever-deeper—even artificial—bargain compared to the price of a whole, uncooked chicken at the same store. While a home-roasted chicken represents an idealized American dinner, the rise of the ubiquitous takeout rotisserie chicken is an extreme microcosm of the commodification and exploitation of that vision.</p>
<p>At Costco, the wholesale supermarket chain founded in 1983 with 785 locations in the United States, rotisserie chickens have been widely reported to be a “loss leader” at $4.99 each; they’re sold for less than they cost, but they are there to lure you into the store, so you can buy other goods (at a profit to the company) while you’re shopping. (Representatives at Costco declined to comment for this article.) At many other supermarkets selling cut-rate rotisserie birds, the same strategy has been in place for decades. A spokesperson for Kroger, a supermarket chain with nearly 3,000 stateside locations, says that their rotisserie chicken program began in the 1980s: “Hot rotisserie chickens are a prepared food mainstay for many households,” she added.</p>
<p>Even restaurant chefs have a soft spot for the supermarket entrée. King Phojanakong, chef-owner of <a href="http://www.kumainn.com/" target="_blank" rel="noopener noreferrer">Kuma Inn</a> on New York City’s Lower East Side, remembers that rotisserie chicken was an imperative whenever his family shopped at Costco growing up. Now, he goes with his kids.</p>
<p>“I cook a pot of rice, there’s salad, and that’s dinner,” he says. “The next day, we make a fried rice, and everybody loves it.”</p>
<p>For Moonlynn Tsai, co-owner of <a href="https://www.kopitiamnyc.com/eat" target="_blank" rel="noopener noreferrer">Kopitiam</a>, a Malaysian restaurant on the edge of New York’s Chinatown in Manhattan, rotisserie chicken from Costco was also on rotation in her household growing up in California. She describes it as a “multipurpose meal”: her mother would serve her and her brother the drumsticks on the first night for dinner, then pull the meat off and save it for later, and finally turn the carcass into a stock that would be used for soup.</p>
<p>“What I do is pull the meat off, put it in a pot and make stock, and cook a lot of beans,” says Tyler Kord, chef-owner of <a href="http://www.no7restaurant.com/" target="_blank" rel="noopener noreferrer">No. 7</a> in Fort Greene, Brooklyn. In his latest cookbook, <a href="https://www.amazon.com/Food52-Dynamite-Chicken-Never-Boring-Favorite/dp/1524759007" target="_blank" rel="noopener noreferrer"><em>Dynamite Chicken</em></a>, he includes a recipe for his <a href="https://www.tastecooking.com/recipes/rotisserie-chicken-beans/" target="_blank" rel="noopener noreferrer">“Rotisserie Chicken Beans (aka The Only Thing That Tyler Kord Would Eat If Left to His Own Devices),”</a> which he says he wrangled his editors to include, since it starts off with a rotisserie chicken rather than instructing you how to cook one yourself.</p>
<p>In 2020, the United States is expected to eat an estimated 1 billion rotisserie chickens, according to the National Chicken Council. And yet many of them won’t turn a profit for their retailers—at least not directly. The fact that they double as marketing for so many businesses may help explain why they’re so ubiquitous today. But the economy of roasting many birds at once on mechanically rotating spits—and the sensory appeal of that process—is not to be underestimated.</p>
<p>“You get to the back of a huge, sterile store, and suddenly you smell that smell and you’re somewhere else,” says Maryn McKenna, author of <a href="https://marynmckenna.com/books/big-chicken/" target="_blank" rel="noopener noreferrer"><em>Big Chicken: The Incredible Story of How Antibiotics Created Modern Agriculture and Changed the Way the World Eats</em></a>, about the Costco rotisserie chicken.</p>
<p>In Paris, where she has lived part-time for years, McKenna finds rotisserie chicken at just about every food market, as well as people lining up for their beautifully roast bird. “It’s efficient in terms of cooking, but it’s also very dramatic to walk past that cabinet and see the chickens turning and the potatoes cooking in the fat in the bottom,” she says. In France, these small potatoes and sometimes onions that are cooked in the rotisserie chicken drippings are typically given to the customer along with a whole chicken.</p>
<p>According to Hillary Davis, author of <a href="https://www.amazon.com/French-Comfort-Food-Hillary-Davis/dp/1423636988" target="_blank" rel="noopener noreferrer"><em>French Comfort Food</em></a>, who lived in France for more than a decade, dripping, golden birds in a rotisserie oven—with the pan of potatoes below—are common sights in the food stores of Lyon, Dijon, and Paris. “I can’t walk by and not get one. The smell lures me in,” she says.</p>
<blockquote><p><strong>“I remember thinking to myself, <em>It’s a whole roast chicken, I don’t have to roast a chicken</em>.”</strong></p></blockquote>
<p>The concept of slowly rotating more than one chicken on a spit over a heat source is new to neither American grocery stores nor the streets of Paris. It is depicted in medieval European art dating back to the 14th century. It was prized by Napoleon. When it’s grilled outdoors, it takes on many time-honored formats around the world, from Brazilian churrascarias to Hawaiian huli huli chicken (“huli” meaning “turn”). In the 20th century, gas convection ovens filled to the brim with chickens speared on rods began to pop up in Europe and North America, at food stores and restaurants. But the term “rotisserie” (which can refer to both a shop specializing in roasted meats using this method, or the rotating spits themselves) and the concept of replacing a home-cooked meal with one centered around it, didn’t hit the American zeitgeist until Boston Market (formerly named Boston Chicken) was founded in 1985. Originally opened as a single store in Newtonville, Massachusetts, it capitalized on rotisserie chicken in a way that its founders hadn’t seen before in the United States—and it grew into a multinational franchise.</p>
<p>Kip Kolow, cofounder of Boston Market (and now chief strategy officer of Cowboy Chicken), remembers the rotisserie chicken that was available in local delis where he grew up in the Boston metro area. But they were just okay, he says, and they weren’t the focal point of the shop—just “ancillary” to the other offerings. They were mostly using “planetary type carousels that would just go around and around” he says, referring to an oven system in which the chickens are speared on horizontal spits arranged around a wheel, which constantly orbit while the individual spits rotate the chickens. When he and business partner, Arthur Cores, opened Boston Chicken, following extensive travel around Europe for research, they used a roasting oven comprised of seven vertically stacked spits of five chickens each; these spits only rotated the chickens but otherwise did not move up and down, allowing each row’s chickens to absorb the drippings from the ones above. The result was a deeply lacquered, crisp skin and richly flavored meat.</p>
<p>“Ours were really the best, because it was seven lines of chicken that were basting one another,” he says. (This is not the oven setup that Boston Market currently uses, however, which is a planetary system.)</p>
<p>But with either mechanism, rotisserie chicken is just different from home-roasted chickens, says Kolow. “Rotisserie chicken has a different caramelization, different moisture content, and you’ll never have better skin,” says Kolow. “It’s a great benefit that we can’t have in the house.”</p>
<p>Neither Kolow nor Boston Market’s current president, Randy Miller, would share the seasonings that Boston Market uses on their chicken, although Miller described it as “proprietary sweet garlic and herb spices.” Kolow says that the store’s original marinating process for the chicken was different—and likely more time-consuming—than the prevailing methods used throughout the food industry today: “Most of them inject things with spice, which changes the texture.”</p>
<p>Injecting birds with seasonings is one step that is not in your typical home-cooked chicken recipe. Neither are the food additives that can be found on many ingredient labels for rotisserie chickens—Costco’s, for instance, have <a href="https://melmagazine.com/en-us/story/whats-in-this-kirkland-seasoned-rotisserie-chicken" target="_blank" rel="noopener noreferrer">ten ingredients</a>, including sodium phosphate, carrageenan, and dextrose. With others, Emma Feigenbaum suspects that caramel color, a substance that she uses a lot in food styling, is partly responsible for that dark glaze. These are common food additives used in processed foods, some of which have been controversial. But there are several more questionable practices behind a whole, cooked chicken that retails for as little as $4.99.</p>
<p>“It’s going to be the cheapest chicken they can put up there,” says Andrew Gunther, executive director of <a href="https://agreenerworld.org/" target="_blank" rel="noopener noreferrer">A Greener World</a>, a nonprofit organization that certifies the voluntary <a href="https://agreenerworld.org/certifications/" target="_blank" rel="noopener noreferrer">production claim</a> program for Animal Welfare Approved, among others. “It’s still chicken, but it’s not been outdoors, and it’s going to have been grown as quickly as it can be by a contract farmer who has absolutely no rights,” he says. The financial situation of contract farmers who supply the heavily consolidated chicken industry’s large corporations with birds, he says, is so fraught that the growers are often stuck in massive debt and don’t earn enough to crawl out of it; it’s a long-standing issue that has been well documented, including in popular documentaries such as <em>Food, Inc.</em></p>
<p>Then, there are the perilous working conditions of slaughter and processing plants, which are largely staffed by immigrants and people of color. These corporations have been criticized for making workers perform at breakneck speeds, which leads to more accidents, and with so few breaks that they have been reported to wear <a href="https://www.nbcnews.com/business/business-news/poultry-workers-denied-bathroom-breaks-wear-diapers-oxfam-report-n572806" target="_blank" rel="noopener noreferrer">adult diapers</a> so that they don’t have to stop to use the restroom. These issues have been exacerbated in the age of COVID-19, as poultry processing workers test positive for the disease and <a href="https://thecounter.org/poultry-worker-groups-tyson-jbs-covid-19-civil-rights/" target="_blank" rel="noopener noreferrer">critics accuse</a> the corporations of doing little to safeguard them. (Meanwhile, the Trump administration has issued an executive order to keep these plants open during the pandemic, citing <a href="https://www.motherjones.com/food/2020/05/packing-execs-say-america-is-running-out-of-meat-while-shipping-ever-more-pork-overseas/" target="_blank" rel="noopener noreferrer">dubious claims</a> of a “meat shortage,” and pandemic recovery bills are tied to mandates to <a href="https://www.latimes.com/business/story/2020-07-29/covid-employer-liability" target="_blank" rel="noopener noreferrer">shield corporations</a> from worker liability.)</p>
<p>“There is no such thing as cheap food—there is a consequence. Something has been compromised to give you that product,” says Gunther.</p>
<p>There is also a noticeable flavor and textural difference between a chicken that’s been raised in confinement and one that hasn’t. Pasture-raised birds that have used their bodies more, thanks to not being cramped in an enclosed barn with nowhere to roam, have a deeper taste and more prominent texture, says Gunther. But to the American palate, that’s not always a good thing.</p>
<p>“When we say something tastes like chicken, we really mean it doesn’t taste like anything,” says McKenna. “In America, it’s a bland, white protein, but that’s not true for other parts of the world, and it’s not true for pasture-raised chickens, because the animals have exercised.”</p>
<p>She says that birds raised in the “classic floor system” of the majority of US producers yields a mellower-tasting, paler, and more fatty flesh, and they’re typically slaughtered much younger than higher welfare birds. That’s the typical American chicken today. Over the years, however, some producers, including the multinational Perdue, have listened to animal welfare activists and implemented more ways for birds to exercise within the floor system, like adding windows, bales of hay, or palettes for birds to walk up and down. McKenna says that shifting to free-range birds may require consumers to reset not only their expectations when it comes to taste or texture but their preparation methods. Free-range chickens often benefit from a slower, lower-temperature roast, she says. “Just bunging a whole chicken into an oven at 400 degrees may not work with a higher welfare bird.”</p>
<p>When customers shop for a raw chicken in a supermarket, they typically face a number of choices, including organic or free-range from producers who voluntarily applied for these labels. With hot rotisserie chicken, it’s often much more opaque. Since labeling requirements differ for prepared foods and raw ones, not knowing how a rotisserie chicken was raised might even be part of the charm: It’s out of sight, and out of mind.</p>
<p>Gunther is mystified by this blasé attitude: “If you buy a car, you want to know everything about it: when it was last serviced, its safety ratings . . . then you pop off to a supermarket, where you actually put the stuff inside you, and you don’t ask how it was fed or how it was raised?”</p>
<p>Few supermarkets offer varieties—and when they do, as in Kroger’s <a href="https://www.kroger.com/p/simple-truth-hot-whole-roasted-chicken-not-available-for-orders-before-11-00-am-daily-/0004157311786" target="_blank" rel="noopener noreferrer">Simple Truth&#x2122; Natural Roasted Chicken</a>, which touts no antibiotics, hormones, or artificial ingredients, the price point is much higher, offered online at $9.99 each, as opposed to $5.99 to $6.99 for their <a href="https://www.kroger.com/p/deli-fresh-hot-whole-roasted-chicken-not-available-for-orders-before-11-00-am-daily-/0001111006182" target="_blank" rel="noopener noreferrer">Savory Rotisserie Chicken</a>.</p>
<p>McKenna says she will occasionally buy a rotisserie chicken from her local Whole Foods in Atlanta, because she feels good about the chicken producers that the store sells in their meat department—including White Oak Pastures, a generative agriculture farm, and Bell &amp; Evans, which is family-owned. “My assumption has always been that Whole Foods was cooking the chickens in its cases that are not selling,” she says.</p>
<p>While it sounds like a logical way for stores to recoup the cost of their products—and might help save some food waste—this is not, however, the way it works at Whole Foods, nor at most grocery stores. A spokesperson for Whole Foods who confirmed that their stores order fresh, new chickens for their rotisserie program added, “Like all our meat, our rotisserie chickens meet our high-quality standards for transparency and traceability to farm or ranch, no antibiotics, and no added growth hormones.” These are offered at Whole Foods stores around the country at $9.99 for an organic rotisserie chicken and $6.99 to $7.99 for the non-organic option.</p>
<p>A spokesperson for the National Chicken Council, Tom Super, says that rotisserie chickens are raised specifically for that purpose as an industry-wide practice: “They are generally much smaller than the whole birds you would find in a meat case,” he says.</p>
<p>Because it requires some investment and demands heavy sales, rotisserie chicken cases aren’t often found in smaller, independent groceries and restaurants. However, a fully roast chicken—and assorted sides—are available from many businesses that may pride themselves on ethical ingredient sourcing.</p>
<p>Tyler Kord says that he prefers the roast chicken at R&amp;D Foods, a small grocery and sandwich shop in Brooklyn, to any rotisserie chickens from supermarkets. There are several other small markets in New York City with comparable offerings, but hovering around $20 for a whole chicken, they aren’t really comparable to a loss-leader supermarket rotisserie bird.</p>
<blockquote><p><strong>Not knowing how a rotisserie chicken was raised might even be part of the charm: It’s out of sight, and out of mind. </strong></p></blockquote>
<p>Eric Rivera, chef-owner of <a href="https://www.ericriveracooks.com/" target="_blank" rel="noopener noreferrer">Addo</a> in Seattle, has added family-style spatchcocked and seasoned chickens to his menu since the pandemic turned his tasting-menu restaurant into a pantry and take-out-only one. His birds are sourced from small local farms that the restaurant works with, and while they aren’t rotisserie-roasted, they’re also not quite fully cooked; after brining and marinating the birds—in a rotating selection of flavors—the chickens are cooked by sous-vide until they’re “90 percent of the way there.” All the customer has to do, he says, is roast them or throw them on a grill for 15–20 minutes.</p>
<p>This ensures a fresh and hot bird whenever the customer is ready to eat, without the overdrying that can plague some rotisserie chickens that are left too long under the heat lamps at a store. But it costs $19.</p>
<p>“If there was a way for me to sell a $5 chicken that checks all the boxes, I would do it,” says Rivera.</p>
<p>Growing up in Washington state, Rivera’s father served in the army and would be away for a couple years at a time. His mother typically cooked for him and his sister, but she would occasionally stop for a takeout rotisserie chicken from the supermarket after picking him up from Little League baseball games.</p>
<p>“My mom would take it and make rice dishes with it, or she would pick it apart and make salad or tacos—it’s endless,” he says. “They were always cheap, and you could feed two to four people.”</p>
<p>The takeout chicken hack felt like a novelty then, he says. Now, it’s much more normal for a family to grab takeout for dinner, because of the convenience.</p>
<p>Of course, another alternative to paying four times the price of a Costco rotisserie chicken is just not buying chicken. But for resourceful parents, it can seem like a poor economic decision when a $5 chicken is less expensive, pound per pound, than many types of vegetables—and is the gateway to soup, stock, and so many leftover meals.</p>
<p>Chicken is an expensive product, says Andrew Gunther of A Greener World—we’ve just been brainwashed to think otherwise. Nowadays, Gunther doesn’t eat much chicken. The inefficiency of converting plants into meat just doesn’t make enough sense. Beef is frequently singled out for requiring many more resources to produce, but chicken still consumes roughly twice as much plant-based protein per output of animal protein.</p>
<p>Labels, like Animal Welfare Approved, can provide consumers more choice in a free market, he says. But when those choices include a ready-to-eat, whole chicken for less than $10, there’s really not much choice for many.</p>
<p>Even Gunther recalls having a rotisserie chicken once in a while, when he and his wife were a young couple: “Because it was all we could afford.”</p>
<p><em><strong>Know Your Chicken</strong>. When America’s favorite protein crosses cultures and winds up on a sheet pan, it’s a winner chicken dinner. Cathy Erway is forever inspired by the chunky, funky poultry and wants you to put this in your oven and roast it. Her book, </em><a href="https://www.amazon.com/Sheet-Pan-Chicken-Simple-Satisfying/dp/1984858548/ref=tmm_hrd_swatch_0?_encoding=UTF8&amp;qid=&amp;sr=" target="_blank" rel="noopener noreferrer">Sheet Pan Chicken</a><em>, arrives this September.</em></p>

        </div>

        
      </section>

      
      <!-- author credit  -->
      <div class="author-credit-wrapper">
  <h3 class="author-name"><a href="https://www.tastecooking.com/author/cerway">Cathy Erway</a></h3>

  
  <p class="author-bio">Cathy Erway is the author of the cookbook The Food of Taiwan and the memoir <i>The Art of Eating In</i>. She hosts the podcasts <i>Self Evident</i>, exploring Asian American stories, and <i>Eat Your Words</i> on Heritage Radio Network, and blogs at Not Eating Out in New York.</p>
</div>

		</article>
	</div><!-- /content-wrapper -->
          </div>
                </div>

                <footer id="footer">
    <div class="footer-recirc">

   <div class="footer-recirc-section featured">
  <div class="footer-recirc-section-header section--latest">
    <h4 class="footer-recirc-section-header--h">Most Recent features</h4>
  </div>
        <div class="footer-recirc-recent-post">
                  <div class="footer-recirc-recent-post-image background-" style="background-image: url(https://www.tastecooking.com/wp-content/uploads/2020/08/Thumb-Postcard-from-Phnom-Penh-Cambodia-150x100.jpg)"></div>
                <div class="footer-recirc-featured--details">
          <div class="footer-recirc-featured--h"><a href="https://www.tastecooking.com/postcard-from-phnom-penh-getting-out-for-curry-puffs/" class="ga-footer-recent">Postcard From Phnom Penh: Getting Out for Curry Puffs</a></div>
          <div class="footer-recirc-featured--date">August 25, 2020</div>
        </div>
      </div>
        <div class="footer-recirc-recent-post">
                  <div class="footer-recirc-recent-post-image background-" style="background-image: url(https://www.tastecooking.com/wp-content/uploads/2020/08/Thumb-Deuki-Hong-Kang-Ho-Dong-Baekjeong-150x100.jpg)"></div>
                <div class="footer-recirc-featured--details">
          <div class="footer-recirc-featured--h"><a href="https://www.tastecooking.com/korean-american-the-deuki-hong-way/" class="ga-footer-recent">Korean American the Deuki Hong Way</a></div>
          <div class="footer-recirc-featured--date">August 24, 2020</div>
        </div>
      </div>
        <div class="footer-recirc-recent-post">
                  <div class="footer-recirc-recent-post-image background-" style="background-image: url(https://www.tastecooking.com/wp-content/uploads/2020/08/Thumb-Chicken-Cutlet-Schnitzel-Milanese-Recipe-150x100.jpg)"></div>
                <div class="footer-recirc-featured--details">
          <div class="footer-recirc-featured--h"><a href="https://www.tastecooking.com/consider-the-cutlet/" class="ga-footer-recent">Consider the Cutlet</a></div>
          <div class="footer-recirc-featured--date">August 20, 2020</div>
        </div>
      </div>
    <a class="footer-recirc-section--view-all" href="/features">View All</a>
</div>

   <div class="footer-recirc-section featured">
  <div class="footer-recirc-section-header section--latest">
    <h4 class="footer-recirc-section-header--h">Most Recent recipes</h4>
  </div>
        <div class="footer-recirc-recent-post">
                  <div class="footer-recirc-recent-post-image background-" style="background-image: url(https://www.tastecooking.com/wp-content/uploads/2020/08/Thumb-Savory-Summer-Cobbler-Recipe-150x100.jpg)"></div>
                <div class="footer-recirc-featured--details">
          <div class="footer-recirc-featured--h"><a href="https://www.tastecooking.com/recipes/summer-cobbler-with-corn-tomatoes-and-pancetta/" class="ga-footer-recent">Summer Cobbler with Corn, Tomatoes, and Pancetta</a></div>
          <div class="footer-recirc-featured--date">August 24, 2020</div>
        </div>
      </div>
        <div class="footer-recirc-recent-post">
                  <div class="footer-recirc-recent-post-image background-" style="background-image: url(https://www.tastecooking.com/wp-content/uploads/2020/08/Thumb-Nopales-Milanese-Cactus-Recipe-150x100.jpg)"></div>
                <div class="footer-recirc-featured--details">
          <div class="footer-recirc-featured--h"><a href="https://www.tastecooking.com/recipes/nopales-milanesa-style-with-tomato-salsa/" class="ga-footer-recent">Nopales Milanesa-Style with Tomato Salsa</a></div>
          <div class="footer-recirc-featured--date">August 18, 2020</div>
        </div>
      </div>
        <div class="footer-recirc-recent-post">
                  <div class="footer-recirc-recent-post-image background-" style="background-image: url(https://www.tastecooking.com/wp-content/uploads/2020/08/Thumb-Cooked-Cucumber-Salad-150x100.jpg)"></div>
                <div class="footer-recirc-featured--details">
          <div class="footer-recirc-featured--h"><a href="https://www.tastecooking.com/recipes/sauteed-cucumbers-with-shallots/" class="ga-footer-recent">Sautéed Cucumbers with Shallots</a></div>
          <div class="footer-recirc-featured--date">August 10, 2020</div>
        </div>
      </div>
    <a class="footer-recirc-section--view-all" href="/recipes">View All</a>
</div>

  <div class="footer-recirc-section instagram">
    <div class="footer-recirc-section-header section--instagram">
      <h4 class="footer-recirc-section-header--h">From Instagram</h4>
    </div>
    <div id="instafeed-footer" class="ga-footer-instagram">
      <a href="https://www.instagram.com/p/B1etizhnu7p/">
        <img src="https://scontent.cdninstagram.com/vp/fb5300a3eb8edd5f8791d5a2325ae76f/5E108146/t51.2885-15/sh0.08/e35/p640x640/67959751_508744303224229_4366147018243616020_n.jpg?_nc_ht=scontent.cdninstagram.com" alt="Taste Instagram Photo">
      </a>
    </div>
  </div>

</div>
  
  <div class="newsletter-signup">
  <div class="newsletter-signup__container">

    <div class="newsletter-signup__left">
      <div class="newsletter-signup__title">
        Get TASTE (Almost) Daily
      </div>

      <div class="newsletter-signup__subtitle">
        The latest in food culture, cooking, and more.
      </div>

      <div class="newsletter-signup__form">
									  <div class="email-subscribe exp-subscribe subscribe">
    <div class="alert alert-success exp-success ga-etembed-success" style="display:none;">
      Great! You've signed up successfully!    </div>
    <div class="alert alert-danger exp-error" style="display:none;">
      We are experiencing an error, please try again.    </div>

    
    <form name="subscribe" id="email-signup" class="email-signup-form" action="https://www.tastecooking.com/wp-admin/admin-ajax.php" method="POST" target="_top" data-event-assigned="false">
      <fieldset class="form-group form-inline email-submit-group">
        <label for="email-address" class="sr-only">Email Address</label>
        <input id="email-newsletter" type="email" placeholder="your@email.com" class="email-newsletter text email form-control" name="email" value="">
        <button type="submit" value="Subscribe" name="subscribe" class="btn btn-primary email-submit-btn ga-general-signup">
					<i class="fa fa-envelope"></i> Subscribe        </button>
      </fieldset>

                        <small class="exp-small terms" style="">
            By clicking Subscribe, I acknowledge that I have read and agree to the Penguin Random House <a href="http://www.penguinrandomhouse.com/privacy/" target="_blank">Privacy Policy</a> and <a href="http://www.penguinrandomhouse.com/terms/" target="_blank">Terms of Use</a> and agree to receive news and updates from TASTE and Penguin Random House.
          </small>
              
      <fieldset class="field-group checkboxes" style="display:none">
                  <div class="checkbox">
            <label>
              <input type="checkbox" name="programs[]" value="505,50501,1" class="exp-checkbox" checked="checked">
              <span><strong>Tastebook General</strong></span>
            </label>
          </div>
                  <div class="checkbox">
            <label>
              <input type="checkbox" name="programs[]" value="505,50502,1" class="exp-checkbox" checked="checked">
              <span><strong>Tastebook Promo</strong></span>
            </label>
          </div>
              </fieldset><!-- /.checkboxes -->

      <input type="hidden" name="data_acq_code" value="TASTE_STATIC_ONGOING" />
      <input type="hidden" name="data_programs" value="50501|505,50502|505" />
      <input type="hidden" name="form_id" value="1" />
      <input type="hidden" name="partner" value="" />
      <input type="hidden" name="action" value="crown_email_signup_submit" />
      <input type="hidden" name="ref_url" value="" />
    </form>

    
  </div>

  <script>
    jQuery(document).ready(function () {
      var unassigned_forms;

      setInterval( function() {

        //Check for unassigned forms
        var forms = jQuery( '.email-signup-form' );
        unassigned_forms = false;

        forms.each( function( index ) {
          if ( jQuery( this ).attr( 'data-event-assigned' ) === 'false' ) {
            unassigned_forms = true;
          }
        });

        if ( unassigned_forms ) {

          forms.off( 'submit' ).on( 'submit', function ( e ) {

            forms.attr( 'data-event-assigned', 'true' );

                        e.preventDefault();
            // Basic email validation
            var email = jQuery(e.target).find('.email-newsletter').val(),
              valid_email = false,
              groupEl = jQuery(e.target).closest('.email-subscribe');


            if ( !!email && typeof(email) === "string" ) {
              var email_array = email.split('@');
              if ( email_array.length === 2 ) {
                if ( email_array[1].split('.').length > 1 ) {
                  valid_email = true;
                }
              }
            }

            if ( valid_email ) {
              jQuery('.alert-danger').hide();
              // Show loading gif
              groupEl.find('.email-signup-form').hide();
              groupEl.find('.email-submit-loading').show();

              // Populate ref_url
              jQuery(this).find('input[name="ref_url"]').val(window.location.href);

              // Generate Payload
              var payload = jQuery(this).serializeArray();

              
              jQuery.ajax({
                url: jQuery(this).attr('action'),
                type: 'POST',
                data: payload,
                success: function (data) {
                                    // Hide loading spinner
                  groupEl.find('.email-signup-form').show();
                  groupEl.find('.email-submit-loading').hide();
                  // Display success msg
                  var target = jQuery(e.target);
                  jQuery(e.target).hide();
                  jQuery(e.target).parent().find('.alert-success').show();
                  jQuery(e.target).parent().find('#downloadbtn').show();
                },
                fail: function (err) {
                                    // Hide loading spinner
                  groupEl.find('.email-signup-form').show();
                  groupEl.find('.email-submit-loading').hide();
                  // Display failure msg
                  var target = jQuery(e.target);
                  jQuery(e.target).hide();
                  jQuery(e.target).parent().find('.alert-danger').show();
                }
              });
            }
            else {
              groupEl.find('.alert-danger').html('Please enter a valid email address.').show();
            }
          });

          forms.off( 'keypress' ).on( 'keypress', function ( e ) {
            if ( e.which === 13 ) {
              e.preventDefault();
              jQuery( this ).submit();
            }
          });

        }
      }, 100);
    });
  </script>

  
				      </div>

    </div>

    <div class="newsletter-signup__right">
      <img src="https://www.tastecooking.com/wp-content/uploads/2019/11/Asset-footer@2x.png" alt="" width="300">
    </div>

  </div>
</div>

	<nav class="footer-nav">

    <div class="footer-nav__logo">
      <a href="https://www.tastecooking.com"> <svg width="140" height="43" viewBox="0 0 140 43" fill="none" xmlns="http://www.w3.org/2000/svg">
<path d="M17.0912 42.4512H8.88497V7.52832H0V0.494385H25.9762V7.52832H17.0912V42.4512Z" fill="black"/>
<path d="M38.684 42.4504H30.4778V11.4764C30.4778 8.02115 31.6193 5.2446 33.9022 3.14676C36.1851 1.04892 39.1345 0 42.7563 0C46.4584 0 49.42 1.03658 51.6413 3.11591C53.8625 5.19524 54.9732 7.97796 54.9732 11.4764V42.4504H46.7669V34.1208H38.684V42.4504ZM38.684 12.2168V27.0868H46.7669V12.2168C46.7669 10.6928 46.409 9.47113 45.6871 8.54561C44.9652 7.6201 43.9903 7.15734 42.7563 7.15734C41.4791 7.15734 40.4857 7.60776 39.7638 8.51476C39.0419 9.42177 38.684 10.6558 38.684 12.2168Z" fill="black"/>
<path d="M84.7774 31.4676C84.7774 34.8427 83.6051 37.5945 81.2604 39.7356C78.9158 41.8766 75.9109 42.944 72.2521 42.944C68.6734 42.944 65.7549 41.9075 63.4905 39.8281C61.2261 37.7488 60.0969 34.9846 60.0969 31.5293V29.1847H67.7479V31.2208C67.7479 32.5782 68.1674 33.6889 69.0127 34.5527C69.858 35.4165 70.9563 35.8484 72.3138 35.8484C73.5478 35.8484 74.5535 35.4658 75.3371 34.7069C76.1207 33.948 76.5094 32.9299 76.5094 31.6527C76.5094 30.7889 76.2626 30.0176 75.769 29.3389C75.2754 28.6602 74.3067 27.7655 72.8691 26.6549L67.0075 22.2741C64.6196 20.5033 62.892 18.7448 61.8246 16.9987C60.7571 15.2525 60.2203 13.346 60.2203 11.2913C60.2203 8.00264 61.3803 5.29396 63.7064 3.17761C66.0264 1.06126 68.9572 0 72.4989 0C76.0343 0 78.8973 1.04892 81.0753 3.14676C83.2534 5.2446 84.3455 8.06435 84.3455 11.5998V13.636H76.6945V11.7849C76.6945 10.3843 76.3058 9.26752 75.5222 8.42221C74.7386 7.57691 73.7144 7.15734 72.4372 7.15734C71.2031 7.15734 70.2283 7.50904 69.5064 8.20626C68.7845 8.90348 68.4266 9.829 68.4266 10.9828C68.4266 11.7664 68.6734 12.5377 69.167 13.2966C69.6606 14.0555 70.4195 14.8268 71.4499 15.6104L78.2371 20.855C80.5817 22.706 82.26 24.4522 83.2657 26.0996C84.2714 27.747 84.7774 29.5364 84.7774 31.4676Z" fill="black"/>
<path d="M104.211 42.4512H96.0049V7.52832H87.1199V0.494385H113.096V7.52832H104.211V42.4512Z" fill="black"/>
<path d="M140 42.4512H118.219V0.494385H140V7.52832H126.425V17.7707H139.753V24.8047H126.425V35.4173H140V42.4512Z" fill="black"/>
</svg>
 </a>
    </div>

		<div class="footer-nav-links">
			<a class="footer-nav-link" href="https://www.tastecooking.com/about_us/">About Us</a>
			<a class="footer-nav-link" href="http://www.penguinrandomhouse.com/privacy/" target="_blank">Privacy & Cookies</a>
			<a class="footer-nav-link" href="http://www.penguinrandomhouse.com/terms/" target="_blank">Terms</a>
		</div>
    <div class="ccpa-link">
      <a href="https://www.penguinrandomhouse.com/privacy/right-to-opt-out-of-sale-form/" target="_blank">Do Not Sell My Personal Information</a>
		</div>

		<div class="footer-copyright">
      Copyright 2020 - Taste, A Division of Penguin Random House LLC.<br/>
      All Rights Reserved.
		</div>

    <div class="footer-social-links">
      <a class="social-link facebook" href="https://www.facebook.com/tastecookingmag" target="_blank"></a>
<a class="social-link twitter" href="https://twitter.com/taste_cooking" target="_blank"></a>
<a class="social-link pinterest" href="https://www.pinterest.com/tastecooking" target="_blank"></a>
<a class="social-link instagram" href="https://www.instagram.com/taste" target="_blank"></a>
    </div>

	</nav>
</footer>
        
      <!-- BEGIN: wpflow ga events array -->
      <script defer>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</script>
      <!-- END: wpflow ga events array --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: TASTE mobile --><div id="om-yllqxpq3hydo33jof1fm-holder"></div><script>var yllqxpq3hydo33jof1fm,yllqxpq3hydo33jof1fm_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){yllqxpq3hydo33jof1fm_poll(function(){if(window['om_loaded']){if(!yllqxpq3hydo33jof1fm){yllqxpq3hydo33jof1fm=new OptinMonsterApp();return yllqxpq3hydo33jof1fm.init({"u":"14532.581905","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.optnmstr.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;yllqxpq3hydo33jof1fm=new OptinMonsterApp();yllqxpq3hydo33jof1fm.init({"u":"14532.581905","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><!-- / OptinMonster --><!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: Taste Lead Gen --><div id="om-fntpsrdsndv0uani-holder"></div><script>var fntpsrdsndv0uani,fntpsrdsndv0uani_poll=function(){var r=0;return function(n,l){clearInterval(r),r=setInterval(n,l)}}();!function(e,t,n){if(e.getElementById(n)){fntpsrdsndv0uani_poll(function(){if(window['om_loaded']){if(!fntpsrdsndv0uani){fntpsrdsndv0uani=new OptinMonsterApp();return fntpsrdsndv0uani.init({"u":"14532.551413","staging":0,"dev":0,"beta":0});}}},25);return;}var d=false,o=e.createElement(t);o.id=n,o.src="https://a.optnmstr.com/app/js/api.min.js",o.async=true,o.onload=o.onreadystatechange=function(){if(!d){if(!this.readyState||this.readyState==="loaded"||this.readyState==="complete"){try{d=om_loaded=true;fntpsrdsndv0uani=new OptinMonsterApp();fntpsrdsndv0uani.init({"u":"14532.551413","staging":0,"dev":0,"beta":0});o.onload=o.onreadystatechange=null;}catch(t){}}}};(document.getElementsByTagName("head")[0]||document.documentElement).appendChild(o)}(document,"script","omapi-script");</script><!-- / OptinMonster --><div style="position:absolute;overflow:hidden;clip:rect(0 0 0 0);height:1px;width:1px;margin:-1px;padding:0;border:0"><div class="omapi-shortcode-helper">[email_signup id="3"]</div><div class="omapi-shortcode-parsed omapi-encoded">  &lt;div class=&quot;email-subscribe exp-subscribe subscribe&quot;&gt;
    &lt;div class=&quot;alert alert-success exp-success ga-etembed-success&quot; style=&quot;display:none;&quot;&gt;
      Great! You've signed up successfully!    &lt;/div&gt;
    &lt;div class=&quot;alert alert-danger exp-error&quot; style=&quot;display:none;&quot;&gt;
      We are experiencing an error, please try again.    &lt;/div&gt;

    
    &lt;form name=&quot;subscribe&quot; id=&quot;email-signup&quot; class=&quot;email-signup-form&quot; action=&quot;https://www.tastecooking.com/wp-admin/admin-ajax.php&quot; method=&quot;POST&quot; target=&quot;_top&quot; data-event-assigned=&quot;false&quot;&gt;
      &lt;fieldset class=&quot;form-group form-inline email-submit-group&quot;&gt;
        &lt;label for=&quot;email-address&quot; class=&quot;sr-only&quot;&gt;Email Address&lt;/label&gt;
        &lt;input id=&quot;email-newsletter&quot; type=&quot;email&quot; placeholder=&quot;your@email.com&quot; class=&quot;email-newsletter text email form-control&quot; name=&quot;email&quot; value=&quot;&quot;&gt;
        &lt;button type=&quot;submit&quot; value=&quot;Subscribe&quot; name=&quot;subscribe&quot; class=&quot;btn btn-primary email-submit-btn ga-etembed-success&quot;&gt;
					&lt;i class=&quot;fa fa-envelope&quot;&gt;&lt;/i&gt; Subscribe        &lt;/button&gt;
      &lt;/fieldset&gt;

                        &lt;small class=&quot;exp-small terms&quot; style=&quot;&quot;&gt;
            By clicking Subscribe, I acknowledge that I have read and agree to the Penguin Random House &lt;a href=&quot;http://www.penguinrandomhouse.com/privacy/&quot; target=&quot;_blank&quot;&gt;Privacy Policy&lt;/a&gt; and &lt;a href=&quot;http://www.penguinrandomhouse.com/terms/&quot; target=&quot;_blank&quot;&gt;Terms of Use&lt;/a&gt; and agree to receive news and updates from TASTE and Penguin Random House.
          &lt;/small&gt;
              
      &lt;fieldset class=&quot;field-group checkboxes&quot; style=&quot;display:none&quot;&gt;
                  &lt;div class=&quot;checkbox&quot;&gt;
            &lt;label&gt;
              &lt;input type=&quot;checkbox&quot; name=&quot;programs[]&quot; value=&quot;505,50501,1&quot; class=&quot;exp-checkbox&quot; checked=&quot;checked&quot;&gt;
              &lt;span&gt;&lt;strong&gt;Tastebook General&lt;/strong&gt;&lt;/span&gt;
            &lt;/label&gt;
          &lt;/div&gt;
                  &lt;div class=&quot;checkbox&quot;&gt;
            &lt;label&gt;
              &lt;input type=&quot;checkbox&quot; name=&quot;programs[]&quot; value=&quot;505,50502,1&quot; class=&quot;exp-checkbox&quot; checked=&quot;checked&quot;&gt;
              &lt;span&gt;&lt;strong&gt;Tastebook Promo&lt;/strong&gt;&lt;/span&gt;
            &lt;/label&gt;
          &lt;/div&gt;
              &lt;/fieldset&gt;&lt;!-- /.checkboxes --&gt;

      &lt;input type=&quot;hidden&quot; name=&quot;data_acq_code&quot; value=&quot;TASTE_POPUP_STATIC_ONGOING&quot; /&gt;
      &lt;input type=&quot;hidden&quot; name=&quot;data_programs&quot; value=&quot;50501|505,50502|505&quot; /&gt;
      &lt;input type=&quot;hidden&quot; name=&quot;form_id&quot; value=&quot;3&quot; /&gt;
      &lt;input type=&quot;hidden&quot; name=&quot;partner&quot; value=&quot;&quot; /&gt;
      &lt;input type=&quot;hidden&quot; name=&quot;action&quot; value=&quot;crown_email_signup_submit&quot; /&gt;
      &lt;input type=&quot;hidden&quot; name=&quot;ref_url&quot; value=&quot;&quot; /&gt;
    &lt;/form&gt;

    
  &lt;/div&gt;

  &lt;script&gt;
    jQuery(document).ready(function () {
      var unassigned_forms;

      setInterval( function() {

        //Check for unassigned forms
        var forms = jQuery( '.email-signup-form' );
        unassigned_forms = false;

        forms.each( function( index ) {
          if ( jQuery( this ).attr( 'data-event-assigned' ) === 'false' ) {
            unassigned_forms = true;
          }
        });

        if ( unassigned_forms ) {

          forms.off( 'submit' ).on( 'submit', function ( e ) {

            forms.attr( 'data-event-assigned', 'true' );

                        e.preventDefault();
            // Basic email validation
            var email = jQuery(e.target).find('.email-newsletter').val(),
              valid_email = false,
              groupEl = jQuery(e.target).closest('.email-subscribe');


            if ( !!email &amp;&amp; typeof(email) === &quot;string&quot; ) {
              var email_array = email.split('@');
              if ( email_array.length === 2 ) {
                if ( email_array[1].split('.').length &gt; 1 ) {
                  valid_email = true;
                }
              }
            }

            if ( valid_email ) {
              jQuery('.alert-danger').hide();
              // Show loading gif
              groupEl.find('.email-signup-form').hide();
              groupEl.find('.email-submit-loading').show();

              // Populate ref_url
              jQuery(this).find('input[name=&quot;ref_url&quot;]').val(window.location.href);

              // Generate Payload
              var payload = jQuery(this).serializeArray();

              
              jQuery.ajax({
                url: jQuery(this).attr('action'),
                type: 'POST',
                data: payload,
                success: function (data) {
                                    // Hide loading spinner
                  groupEl.find('.email-signup-form').show();
                  groupEl.find('.email-submit-loading').hide();
                  // Display success msg
                  var target = jQuery(e.target);
                  jQuery(e.target).hide();
                  jQuery(e.target).parent().find('.alert-success').show();
                  jQuery(e.target).parent().find('#downloadbtn').show();
                },
                fail: function (err) {
                                    // Hide loading spinner
                  groupEl.find('.email-signup-form').show();
                  groupEl.find('.email-submit-loading').hide();
                  // Display failure msg
                  var target = jQuery(e.target);
                  jQuery(e.target).hide();
                  jQuery(e.target).parent().find('.alert-danger').show();
                }
              });
            }
            else {
              groupEl.find('.alert-danger').html('Please enter a valid email address.').show();
            }
          });

          forms.off( 'keypress' ).on( 'keypress', function ( e ) {
            if ( e.which === 13 ) {
              e.preventDefault();
              jQuery( this ).submit();
            }
          });

        }
      }, 100);
    });
  &lt;/script&gt;

  </div></div><div style="position:absolute;overflow:hidden;clip:rect(0 0 0 0);height:1px;width:1px;margin:-1px;padding:0;border:0"><div class="omapi-shortcode-helper">[email_signup id="3"]</div><div class="omapi-shortcode-parsed omapi-encoded">  &lt;div class=&quot;email-subscribe exp-subscribe subscribe&quot;&gt;
    &lt;div class=&quot;alert alert-success exp-success ga-etembed-success&quot; style=&quot;display:none;&quot;&gt;
      Great! You've signed up successfully!    &lt;/div&gt;
    &lt;div class=&quot;alert alert-danger exp-error&quot; style=&quot;display:none;&quot;&gt;
      We are experiencing an error, please try again.    &lt;/div&gt;

    
    &lt;form name=&quot;subscribe&quot; id=&quot;email-signup&quot; class=&quot;email-signup-form&quot; action=&quot;https://www.tastecooking.com/wp-admin/admin-ajax.php&quot; method=&quot;POST&quot; target=&quot;_top&quot; data-event-assigned=&quot;false&quot;&gt;
      &lt;fieldset class=&quot;form-group form-inline email-submit-group&quot;&gt;
        &lt;label for=&quot;email-address&quot; class=&quot;sr-only&quot;&gt;Email Address&lt;/label&gt;
        &lt;input id=&quot;email-newsletter&quot; type=&quot;email&quot; placeholder=&quot;your@email.com&quot; class=&quot;email-newsletter text email form-control&quot; name=&quot;email&quot; value=&quot;&quot;&gt;
        &lt;button type=&quot;submit&quot; value=&quot;Subscribe&quot; name=&quot;subscribe&quot; class=&quot;btn btn-primary email-submit-btn ga-etembed-success&quot;&gt;
					&lt;i class=&quot;fa fa-envelope&quot;&gt;&lt;/i&gt; Subscribe        &lt;/button&gt;
      &lt;/fieldset&gt;

                        &lt;small class=&quot;exp-small terms&quot; style=&quot;&quot;&gt;
            By clicking Subscribe, I acknowledge that I have read and agree to the Penguin Random House &lt;a href=&quot;http://www.penguinrandomhouse.com/privacy/&quot; target=&quot;_blank&quot;&gt;Privacy Policy&lt;/a&gt; and &lt;a href=&quot;http://www.penguinrandomhouse.com/terms/&quot; target=&quot;_blank&quot;&gt;Terms of Use&lt;/a&gt; and agree to receive news and updates from TASTE and Penguin Random House.
          &lt;/small&gt;
              
      &lt;fieldset class=&quot;field-group checkboxes&quot; style=&quot;display:none&quot;&gt;
                  &lt;div class=&quot;checkbox&quot;&gt;
            &lt;label&gt;
              &lt;input type=&quot;checkbox&quot; name=&quot;programs[]&quot; value=&quot;505,50501,1&quot; class=&quot;exp-checkbox&quot; checked=&quot;checked&quot;&gt;
              &lt;span&gt;&lt;strong&gt;Tastebook General&lt;/strong&gt;&lt;/span&gt;
            &lt;/label&gt;
          &lt;/div&gt;
                  &lt;div class=&quot;checkbox&quot;&gt;
            &lt;label&gt;
              &lt;input type=&quot;checkbox&quot; name=&quot;programs[]&quot; value=&quot;505,50502,1&quot; class=&quot;exp-checkbox&quot; checked=&quot;checked&quot;&gt;
              &lt;span&gt;&lt;strong&gt;Tastebook Promo&lt;/strong&gt;&lt;/span&gt;
            &lt;/label&gt;
          &lt;/div&gt;
              &lt;/fieldset&gt;&lt;!-- /.checkboxes --&gt;

      &lt;input type=&quot;hidden&quot; name=&quot;data_acq_code&quot; value=&quot;TASTE_POPUP_STATIC_ONGOING&quot; /&gt;
      &lt;input type=&quot;hidden&quot; name=&quot;data_programs&quot; value=&quot;50501|505,50502|505&quot; /&gt;
      &lt;input type=&quot;hidden&quot; name=&quot;form_id&quot; value=&quot;3&quot; /&gt;
      &lt;input type=&quot;hidden&quot; name=&quot;partner&quot; value=&quot;&quot; /&gt;
      &lt;input type=&quot;hidden&quot; name=&quot;action&quot; value=&quot;crown_email_signup_submit&quot; /&gt;
      &lt;input type=&quot;hidden&quot; name=&quot;ref_url&quot; value=&quot;&quot; /&gt;
    &lt;/form&gt;

    
  &lt;/div&gt;

  &lt;script&gt;
    jQuery(document).ready(function () {
      var unassigned_forms;

      setInterval( function() {

        //Check for unassigned forms
        var forms = jQuery( '.email-signup-form' );
        unassigned_forms = false;

        forms.each( function( index ) {
          if ( jQuery( this ).attr( 'data-event-assigned' ) === 'false' ) {
            unassigned_forms = true;
          }
        });

        if ( unassigned_forms ) {

          forms.off( 'submit' ).on( 'submit', function ( e ) {

            forms.attr( 'data-event-assigned', 'true' );

                        e.preventDefault();
            // Basic email validation
            var email = jQuery(e.target).find('.email-newsletter').val(),
              valid_email = false,
              groupEl = jQuery(e.target).closest('.email-subscribe');


            if ( !!email &amp;&amp; typeof(email) === &quot;string&quot; ) {
              var email_array = email.split('@');
              if ( email_array.length === 2 ) {
                if ( email_array[1].split('.').length &gt; 1 ) {
                  valid_email = true;
                }
              }
            }

            if ( valid_email ) {
              jQuery('.alert-danger').hide();
              // Show loading gif
              groupEl.find('.email-signup-form').hide();
              groupEl.find('.email-submit-loading').show();

              // Populate ref_url
              jQuery(this).find('input[name=&quot;ref_url&quot;]').val(window.location.href);

              // Generate Payload
              var payload = jQuery(this).serializeArray();

              
              jQuery.ajax({
                url: jQuery(this).attr('action'),
                type: 'POST',
                data: payload,
                success: function (data) {
                                    // Hide loading spinner
                  groupEl.find('.email-signup-form').show();
                  groupEl.find('.email-submit-loading').hide();
                  // Display success msg
                  var target = jQuery(e.target);
                  jQuery(e.target).hide();
                  jQuery(e.target).parent().find('.alert-success').show();
                  jQuery(e.target).parent().find('#downloadbtn').show();
                },
                fail: function (err) {
                                    // Hide loading spinner
                  groupEl.find('.email-signup-form').show();
                  groupEl.find('.email-submit-loading').hide();
                  // Display failure msg
                  var target = jQuery(e.target);
                  jQuery(e.target).hide();
                  jQuery(e.target).parent().find('.alert-danger').show();
                }
              });
            }
            else {
              groupEl.find('.alert-danger').html('Please enter a valid email address.').show();
            }
          });

          forms.off( 'keypress' ).on( 'keypress', function ( e ) {
            if ( e.which === 13 ) {
              e.preventDefault();
              jQuery( this ).submit();
            }
          });

        }
      }, 100);
    });
  &lt;/script&gt;

  </div></div>		<script type="text/javascript">
		var yllqxpq3hydo33jof1fm_shortcode = true;var fntpsrdsndv0uani_shortcode = true;		</script>
		<script type='text/javascript' src='https://www.tastecooking.com/wp-includes/js/underscore.min.js?ver=1.8.3' id='underscore-js'></script>
<script type='text/javascript' src='https://www.tastecooking.com/wp-content/themes/taste2/static/build/js/all.min.js?ver=5.5' id='tb_script-js'></script>
<script type='text/javascript' src='https://www.tastecooking.com/wp-content/themes/taste2/static/build/lib/malihu-custom-scrollbar-plugin/jquery.mCustomScrollbar.js?ver=5.5' id='scrollbar_script-js'></script>
<script type='text/javascript' src='https://www.tastecooking.com/wp-content/themes/taste2/static/build/lib/flickity/dist/flickity.pkgd.min.js?ver=5.5' id='flickity-js'></script>
<script type='text/javascript' src='https://www.tastecooking.com/wp-content/themes/taste2/static/build/lib/jquery-mousewheel/jquery.mousewheel.min.js?ver=5.5' id='jquery-mousewheel-js'></script>
<script>(function(d){var s=d.createElement("script");s.type="text/javascript";s.src="https://a.omappapi.com/app/js/api.min.js";s.async=true;s.id="omapi-script";d.getElementsByTagName("head")[0].appendChild(s);})(document);</script><script type='text/javascript' src='https://www.tastecooking.com/wp-content/plugins/mit-tracking/assets/js/ct.js?ver=5.5' id='crown-tracking-scripts-js'></script>
<script type='text/javascript' src='https://www.tastecooking.com/wp-includes/js/wp-embed.min.js?ver=5.5' id='wp-embed-js'></script>
<script type='text/javascript' src='https://www.tastecooking.com/wp-content/plugins/optinmonster/assets/js/helper.js?ver=1.9.14' id='optinmonster-wp-helper-js'></script>
		<script type="text/javascript">var omapi_localized = { ajax: 'https://www.tastecooking.com/wp-admin/admin-ajax.php?optin-monster-ajax-route=1', nonce: '7be26b85f7', slugs: {"yllqxpq3hydo33jof1fm":{"slug":"yllqxpq3hydo33jof1fm","mailpoet":false},"fntpsrdsndv0uani":{"slug":"fntpsrdsndv0uani","mailpoet":false}} };</script>
				<script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":115299,"object_key":"post","object_type":"post","term_ids":[3167,2658,3426]};</script>
		
      
    </section>

        <script type="text/javascript" src="https://s.skimresources.com/js/132190X1594666.skimlinks.js"></script>
  <script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"NRJS-4c0d617201395ea8c73","applicationID":"575190646","transactionName":"ZlxTZUNWXxBWVBZeCl8WcFJFXl4NGEQLWQJdXA==","queueTime":0,"applicationTime":851,"atts":"ShtQEwtMTB4=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
